Version 8 (modified by samuraraujo, 10 years ago)

--

Explorator Instalation

This session describes how to install the Explorator - Semantic Exploration of RDF Data. Explorator is semantic browser for RDF data set. It was build over [Ruby], Ruby-on-Rails and ActiveRDF.

All the steps below were tested in Windows XP, but you can do the same think for others platforms like Linux, Mac, etc.

Prerequisite

You MUST install all the tools below for run the Explorator. Follow the exactly order defined below.

* Install [Ruby]

* Download Sqlite3 dll ( http://www.sqlite.org/sqlitedll-3_6_3.zip) and copy to the ruby_installation\bin directory

* Install Ruby-on-Rails (1 Follow the steps below.)

* Unpack the Explorar.rar wherever you want.

1 Follow the steps below to achieve this task.

Execute each command below in this exactly order for install Rails and ActiveRDF.

gem install sqlite3-ruby 
gem install -v=2.0.2 rails --include-dependencies -y
gem install activemerchant
gem install mime-types
gem install ferret

On windows platform, if prompted, select always the mswin32 option.

ActiveRDF Samur's version

You MUST update the activerdf, activerdf_sparql and activerdf_rdflite by the ones that exist in the Explorator SVN repository.

Configuration

As Explorator is based in ActiveRDF, you can work with a local rdf base or a remote rdf base (sparql endpoint). You can find a sample of how do configurate both of them in the file EXPLORATOR_DIR\lib\dataload.rb.

The default base that is configurate with Explorator uses the a RDFLite adapter and the base that was loaded was the www2008.nt.

Running the Explorator

For run the Explorator, goes to the EXPLORATOR_DIRECTORY and executes the command: ruby script/server

You can run the Explorator inside the AptanaStudio? as well.

Using the Explorator

Open the FIREFOX browser and access  http://localhost:3000/.

Note, the Explorator does not work in Microsoft Internet Explorer.